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Abstract

This document describes general guidelines for our laboratory course. It also presents
and describes the hardware and software needed for the different exercises. This document
was originally authored by Christian Feldbauer.

1 Organizational Things

1.1 Course Webpage

Laboratory handouts (such as this document), source code, and additional information can be
found at http://www.spsc.tugraz.at/courses/dsplab/.

1.2 Schedule

The lab will be held in November and December in the last four (or five) weeks before the
Christmas holidays. For the actual schedule, please visit our course web page. There are six
labs with different titles:

1. Fundamentals of Digital Signal Processing

2. Digital Filter Implementation 1

3. Discrete Fourier Transform

4. Digital Filter Implementation 2

5. Selected Applications

6. Multirate Signal Processing

http://www.spsc.tugraz.at/
http://www.spsc.tugraz.at/courses/dsplab/
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1.3 Rooms

We have two rooms available which are located in Inffeldgasse 16, ground floor. The room
codes are IEEG172 and IEEG180, formerly known as ‘STUD.EDV-RAUM 1’ and ‘STUD.EDV-
RAUM 2’.

In each room we have six workplaces, which are equipped with a PC, DSP board, oscillo-
scope, signal generator, and headphones. On a workplace the lab experiments are accomplished
in groups of two or three students.

1.4 Grading

The grading is based on three things: (i) involvement in executing the experiments, (ii) ability
to answer questions, and (iii) the quality of your report. It is recommended that you prepare
well for the laboratory (handouts, textbooks listed on our webpage, lecture material).

Laboratory Report

You have to write a report during the laboratory afternoon and to deliver it either at the end or
up to one week later via e-mail (use the address of the person who taught the lab, otherwise
your report will not be considered). One report for each group is enough. There is a printer
available in our lab.

• Generation: MS Word, LATEX, handwritten, or mixed

• Language: English or German

• Contents:

– Description of accomplishments of the experiments

– Answers to questions which are sometimes posed in laboratory handouts

– Theoretical expectations of the experiments

– Measurement results (tables, plots, sketches, oscilloscope screenshots)

– Conclusions, agreement/disagreement of your results with theory, reasons, ...

2 Hardware

2.1 DSP Board: Spectrum Digital TMS320C6713 DSK

DSK stands for DSP Starter Kit.

• Texas Instruments TMS320C6713 DSP: Fixed-point and floating-point arithmetic,
eight functional units (two multipliers and six ALUs), 225 MHz clock (≤ 1350 MFLOPS),
32 general-purpose registers of 32 bit word length, 256 kbytes internal L2 memory
(+2x4 kbytes L1 cache), DMA controller (16 channels), external memory interface (32-
bit address space), 2 multichannel buffered serial ports, 2 multichannel audio serial ports,
host port interface, 2 timers
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• External Memory: 16 Mbytes SDRAM at 90 MHz and 512 kbytes flash-programmable
ROM

• USB port and JTAG emulation: load programs from host PC, control DSP (start,
stop, set break points, ...), debugging (step-wise execution, read DSP registers/memory)

• Audio Codec AIC23: two channels, 16–32 bit1 sigma-delta ADC and DAC; sampling
rate 8–96 kHz. Line in, line out, and headphones are connected to additionally mounted
jacks on the acrylic glass cover (see also Figure 1):

input: 3.5 mm stereo audio jack and 2 BNC connectors (the BNC connectors are disabled
when the audio jack is plugged). The programs used in this laboratory read data
only from the left input channel.

output: 3.5 mm stereo audio jack for headphones, 2 BNC connectors for line out

IMPORTANT

! Use the connectors on the acrylic glass cover only.

! Maximum input voltage for the codec is 5.6 VPP.

2.2 Waveform Generator: Agilent 33120A

Specifying Waveform Parameter Values

While working with the signal generator, you will often need to enter a value for a parameter
of the generated waveform. To do this follow these instructions:

• First, choose the desired waveform.

• To modify the frequency of the waveform, press the Freq button and select a value (see
below). To set up an amplitude, push the Ampl button and select a value (see below).
IMPORTANT: To get correctly displayed amplitudes, ensure the output of the waveform
generator is set up for high-impedance loads (SYS MENU →OUT TERM →HIGH

Z ).

• In order to select a parameter value, turn the knob on the front panel of the signal
generator until you reach the desired value. The flashing digit indicates the one that is
incremented/decremented if you turn the knob. You can specify which digit to modify
by pressing the > or < button.

• You can also specify a value by entering it directly: Push Enter Number , input the
required number, and press Enter .

1The programs used in this laboratory initialize the codec for 16 bit samples.
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2.3 Oscilloscope: Agilent 54622D

2.3.1 Triggering

The Agilent 54622D oscilloscope has rich triggering possibilities. Here we explain only the
most important features that might be necessary for accomplishing a particular task.

• Setting up triggering to one of the two input channels. Press Edge in the trigger section
and choose either channel 1 or channel 2 by pressing the corresponding soft key.

• Setting up an external trigger. Press Edge in the trigger section of the oscilloscope’s
controls. Set triggering to external by pressing the corresponding soft key Ext . Note, it
is necessary to connect a BNC cable to the Ext. Trigg. input on the scope’s rear panel.

2.3.2 Using Cursors

You can use cursors to measure waveform parameters—horizontal and vertical markers.

• Press Cursors . On the display, you will see different options for using them. Source

selects the corresponding waveform: channel 1, channel 2, or Math (this option corre-
sponds to performing different mathematical operations over the waveform, e.g., fft). Set
source appropriate for your needs.

• Push the X Y button to choose positioning either for X- or Y-cursors (you have two of
them available for both axes). Turn the � knob to position them.

2.3.3 Useful Features

There are a number of useful features that might help you.

• Averaging: a feature that allows you to get rid of random noise. The output signal of
the codec of our DSP board is relatively noisy. This is mainly caused by higher frequency
noise and cable connection imperfections.
To enable averaging, push Acquire in the Waveform section of the oscilloscope’s front
panel. On the display, choose Averaging by pressing the corresponding soft key. Turn
the � knob to set up an appropriate number of triggering events to be averaged (usually
4 or 8 will already give a sufficient noise removal).

• Saving a screenshot: this feature allows you to save a screenshot of the oscilloscope’s
display to a floppy disk as an image file. So you can easily include it in your report.
To enable this feature, you first have to set some parameters: press Utility →Print

Config . Set Print to=“Disk” and Format=“TIF”. Now, to save the display to a
floppy disk, just insert one in the internal floppy drive and press Quick Print .
Another possibility to make a screenshot in combination with MATLAB is by typing
osc gui at the MATLAB command prompt. This command establishes a connection
to the oscilloscope and lets you download the screen to a MATLAB figure. You can then
copy this figure to your protocol without needing a floppy disk.
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• Saving oscilloscope’s settings: this is a very useful feature that allows you to store all
current scope’s settings in one of the three internal slots. You can restore them whenever
you need. You also have the possibility to save the settings on a floppy disk.
First, set up the oscilloscope’s settings of your needs. When ready, push Save/Recall
→Save and then choose a slot by pressing the To softkey or press New File to store
onto a floppy disk. Push Press to Save to actually save the settings.
To restore saved settings, press Save/Recall →Recall , choose source by pressing
From , and push Press to Recall to actually restore the saved settings.

2.4 Measuring a Frequency Response Using a Sweep

1. Signal Generator

• Connect the SYNC output of the signal generator to the Ext. Trigg. input of
the oscilloscope (you can find this connector on the oscilloscope’s rear panel, see
Figure 1).

• Choose the sine waveform by pressing ∼ .

• On the signal generator, enter the sweep mode: press Shift→Noise .

• Set up the parameters of the sweep: press Shift→< to enter the sweep menu.

• Use > or < to move between menu items and use ∨ or ∧ to choose or leave one.

• Select START F (start frequency) by pressing ∨ . Enter the required parameter
value and confirm with Enter .

• Enter the sweep menu again: Shift→< . Move to STOP F (stop frequency), set
it to the desired value, and press Enter .

• Do similarly to set SWP TIME (sweep time) to 1 (or 5) sec.

2. Oscilloscope

• Press the Edge button in the trigger section of the oscilloscope’s controls. Set
external triggering by pressing the corresponding softkey (Ext). To stabilize the
triggering, press Mode/Coupling and set Mode to “Auto Level” and Coupling

to “AC”.

• In order to get one complete sweep onto the ocsilloscope’s screen, set the time base
to 100 ms/div if the sweep time is 1 sec (or 500 ms/div if 5 sec).

• Shift the time axis (use the ◭◮ knob) by 5 divisions (or equivalently by sweep time

2
)

to place the zero-time marker at the left edge of the screen. Now you will have the
start frequency on the left edge and the stop frequency on the right edge of the
screen.

• The envelope of the upper half of the waveform corresponds to the frequency re-
sponse in linear scale.
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3 Software

3.1 Code Composer Studio 4

3.1.1 General Things

• Before starting Code Composer Studio (CCStudio), ensure that the DSP board is pro-
vided with power and physically connected to the PC’s USB port.

• There should be an icon “Code Composer Studio v4” on the desktop. If necessary, start
CCStudio from the Start menu.

• Before you can load programs into the DSP’s memory, you have to make sure that
the correct target device is selected. To this end, open the target configurations view
(View → Target Configurations ) and make sure that TMS320C6713 is set as
default. By right-clicking on the target, launch the selected configuration.

• For more convenience, you should enable CCStudio to load a DSP program automatically
into the DSP’s memory after a successful compiling/linking. Open the C/C++ projects
view (View → C/C++ Projects ) and enter the properties menu by right-clicking on

the project name. Chose CCS Debug Settings → Debugger and make sure that
the check boxes for Connect to exact CPU and Load Program are active.

3.1.2 TMSC6000 Optimizing C Compiler

There are three possibilities to program TI’s C6000 DSPs: Assembly, Linear Assembly, and
C/C++. In Assembly, you have to allocate every instruction to one of the eight functional
units, and you should ensure that all eight units are working concurrently permanently. In
Linear Assembly and C/C++, the optimizer takes this part. In this laboratory, we mostly use
C/C++ and sometimes may include hand-optimized assembly routines.
C/C++ Data Types and Word Lengths:
char 8 bits
short 16 bits
int 32 bits
long 40 bits
float 32 bits
double 64 bits
pointer 32 bits

3.1.3 Structure of a typical DSP Program for Real-Time Block Processing used
in this Laboratory

main.c does the whole initialization and remains in an endless loop. The function init()
is called, where you can do additional initializations. You can set the sampling rate in
this file.

blocks.h provides constants for the block processing environment, such as size and overlap
of the working buffer.
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isr tttt.c contains the Interrupt Service Routine (ISR) which is triggered by the DMA’s
hardware interrupt. It manages circular buffers the DMA uses to transfer data between
the memory and the codec, and it calls the function processing() where the actual
signal processing happens. The tttt is a substitution for the type of the actual working
buffer (e.g., float or short cmplx).

vectors.asm is the interrupt vector table. There must be an entry for the ISR above.

lnk.cmd contains a memory map and arguments for the linker command (e.g., libraries, heap
size, stack size). Note: check the heap size when your program uses dynamic memory
(malloc) and check the stack size when your program needs large local variables.

userfiles The init() and processing() functions have to be defined here and all the
necessary (global) objects (e.g., additional buffers or filter coefficients).

algorithm modules functions and structures for filters, transforms, ...

Note: In the current version, only samples from the left input channel of the audio codec
are read and processed. However, the processed mono signal is written to both output channels
of the codec. For a detailed description of the block processing environment, see [1].

3.1.4 Building a Program in CCStudio

We will provide you with most of the source code. You can find *.zip files for the different
experiments on our webpage www.spsc.tugraz.at/courses/dsplab/. For a demon-
stration of the block processing environment described above, download /courses/dsplab/
intro/blockprocessing.zip. You can unpack the archive files either in your home di-
rectory (Novell drive L:) or on the local drive (do not forget to delete all local files at the end
of the lab session). For most of the experiments, you have to modify or add source code. All
necessary source files of a DSP program will be bundled to a so-called project.

• Close all open projects in the C/C++ Project view (right-click on the project name
→ Close Project ).

• In the main menu, choose Project→ Import Legacy CCSv3.3 Project and select
the *.pjt file appropriate for your exercise. Press the Finish button.

• In the C/C++ Project view window you can see a list of the source code files of the
project—double-clicking opens the file in an embedded text editor window.

• To build a program, choose Project→Rebuild All from the main menu (or the tool-
bar). This (re)compiles all files of the project, links them to the resulting *.out file,
and loads it into the DSP’s memory2. After source code modifications, in order to save
time, it’s recommended to do an Incremental Build where only the modified source files
are recompiled.

• To run a program, press Debug Launch in the tool bar. Remember that the pro-
gram must be successfully compiled, linked, and loaded into the DSP’s memory. After
the view automatically changed to the Debug view, you can start the code by pressing

2When the ‘automatic load’ option is enabled and the board is connected (see 3.1.1).

http://www.spsc.tugraz.at/courses/dsplab/
http://www.spsc.tugraz.at/courses/dsplab/intro/blockprocessing.zip
http://www.spsc.tugraz.at/courses/dsplab/intro/blockprocessing.zip
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Target → Run . If you terminate the program you automatically step back to the
C/C++ Projects view.

3.2 Matlab

Note: In MATLAB, the indices of vectors or matrices start from one!

3.2.1 sptool

With this program we can design digital filters in an interactive way. The user inputs the
desired specifications such as filter type, filter order, frequency response tolerance, etc. and
the program calculates the corresponding filter coefficients, which can then be used in the
source code of your DSP program.
To design a filter perform the following steps:

• Start Matlab and type >> sptool at the command line. The startup dialog (object
list) appears.

• In the Filter column, click New . A new filter object is created and the Filter Design
dialog appears. For the following, it is assumed that the object is called filt1.

• Construct the desired filter by changing appropriate parameters.

• Go back to the startup dialog. You can view different responses of the designed filter by
clicking View . The Filter Viewer window opens where you can browse through different
graphs (frequency response, impulse response, group delay, etc).

• To extract the coefficients, go back to the startup dialog and choose Export from the
File menu. In the new dialog, select the filt1 object and choose Export to Workspace.
Matlab will save a structure variable called filt1 into the current workspace.

• By typing >> filt1.tf.num’ at the command line, you will be able to see numerator
coefficients of the designed filter and >> filt1.tf.den’ will output the denominator
coefficients. Now, you can copy and paste them to your C source file.

References

[1] Feldbauer, C.: “Real-Time Block Processing Environment,” Laboratory Handout, http:
//www.spsc.tugraz.at/courses/dsplab/intro/blockprocessing.pdf,
2005.

http://www.spsc.tugraz.at/courses/dsplab/intro/blockprocessing.pdf
http://www.spsc.tugraz.at/courses/dsplab/intro/blockprocessing.pdf
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